[Bug 175] New: empty filename include in wchar.h

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 175] New: empty filename include in wchar.h

Bugzilla from bugzilla@busybox.net
https://bugs.busybox.net/show_bug.cgi?id=175

              Host: i386
            Target: i386
           Summary: empty filename include in wchar.h
           Product: buildroot
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P5
         Component: Other
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]
                CC: [hidden email]
   Estimated Hours: 0.0


Created an attachment (id=133)
 --> (https://bugs.busybox.net/attachment.cgi?id=133)
Config file for this build.

When compiling buildroot 2009.02 it I get an error when compiling coreutils:

make[3]: Entering directory
`/mnt/sd/sda/3/buildroot-2009.02/build_i386/coreutils-6.9/lib'
/mnt/sd/sda/3/buildroot-2009.02/build_i386/staging_dir/usr/bin/i386-linux-uclibc-gcc
-Os -pipe -Os
-I/mnt/sd/sda/3/buildroot-2009.02/build_i386/staging_dir/usr/include
-I/mnt/sd/sda/3/buildroot-2009.02/build_i386/staging_dir/include
--sysroot=/mnt/sd/sda/3/buildroot-2009.02/build_i386/staging_dir/ -isysroot
/mnt/sd/sda/3/buildroot-2009.02/build_i386/staging_dir -mtune=i386 -march=i386
-I.      -g -O2 -c allocsa.c
In file included from ./stdint.h:87,
                 from
///mnt/sd/sda/3/buildroot-2009.02/build_i386/staging_dir/usr/include/stdlib.h:860,
                 from ./stdlib.h:44,
                 from allocsa.h:24,
                 from allocsa.c:22:
./wchar.h:41:12: error: empty filename in #include

I checked this wchar.h, an indeed there is an include which is empty:

/* Include the original <wchar.h>.  */
#include ""

I've been trying to build a system with "generic development system", not
changing more.


--
Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
_______________________________________________
buildroot mailing list
[hidden email]
http://lists.busybox.net/mailman/listinfo/buildroot
Reply | Threaded
Open this post in threaded view
|

[Bug 175] empty filename include in wchar.h

Bugzilla from bugzilla@busybox.net
https://bugs.busybox.net/show_bug.cgi?id=175


Peter Korsgaard <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |DUPLICATE




--- Comment #1 from Peter Korsgaard <[hidden email]>  2009-03-11 10:32:43 UTC ---
This sounds similar to #71. You have to enable WCHAR support under toolchain
options. It's fixed in svn trunk.

*** This bug has been marked as a duplicate of bug 71 ***


--
Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
_______________________________________________
buildroot mailing list
[hidden email]
http://lists.busybox.net/mailman/listinfo/buildroot